이 응용프로그램을 설치하거나 실행할 수 없습니다. 먼저 GAC(전역 어셈블리 캐시)에 WindowsBase 버전 3.0.0.0 어셈플리를 설치해야 합니다. 라는 오류가 발생하였다. clickonce 클릭원스로 배포할때 이런 문제가 발생하였다. 클릭원스로 배포하면 배포솔루션에 필요한 파일들이 다 포함이 될텐데 이런문제가 발생하다니 .. 

해결책은 간단하다. GAC(전역 어셈블리 캐시)에 WindowsBase 버전 3.0.0.0 어셈플리를 설치해야 합니다. 라는 오류가 뜨면 닷넷프레임워크를 설치해주고 설치가 되어 있다면 활성화를 시켜주면 된다.

아래의 캡쳐와 같이 기능 선택을 하여 준다.
 


서버관리 > 기능 > .NET Framework 3.5.1 (닷넷 프레임워크)를 체크하여 기능활성화를 해준다.
신고
Tags
  1. Favicon of http://min-blog.tistory.com BlogIcon 백전백승비밀방문자
    2011.11.25 10:14 신고 edit/del reply

    서버에 대해서는 모르는데 서버 작업을 할 때 나오는 에러군요.어셈블리가 제목에 있길래 프로그래밍에 관한 것인 줄 알았거든요. 제가 10년전에 어셈블리 공부를 약간 했거든요.

    • Favicon of http://ndolson.com BlogIcon 엔돌슨비밀방문자
      2011.11.25 10:46 신고 edit/del

      어셈블리어 어려워요 ㅠㅠ JUMP하고 몇번째줄에서 메모리 어떻게 하고 복잡하게 배웠던 기억이나요.
      사실 닷넷하고 GAC, 어셈블리어 관계를 조금 알아야 하는데 조금밖에 모르겠습니다.
      백전백승님도 개발을 많이 하셨군요^^반가워요

  2. Favicon of http://dora.jogosloucos.com.br/ BlogIcon jogos da dora비밀방문자
    2012.03.02 07:53 신고 edit/del reply

    지금은 오랜 시간 기준으로 윈도우 작업했습니다,하지만 난 여전히 모든 기능을 모르겠어요. 그것은 정말 복잡한 프로그램입니다.